Web3Modal API elevated 400 responses
Incident Report for WalletConnect

Resolved
This incident has been resolved and Web3Modal API is fully operational again.

We are truly sorry for the inconvenience that this may have caused.
We are currently working on improving our services and processes to avoid this in the future.

Thanks for your patience.
Posted Apr 22, 2024 - 14:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
ETA for the API to be fully operational again: 14:45 UTC
Posted Apr 22, 2024 - 14:15 UTC
Identified
The problem has been identified and was caused by a connection issue between our API and our database provider.
Posted Apr 22, 2024 - 14:13 UTC
Investigating
An elevated amount of requests are getting a 400, potentially due to a caching issue.
We are investigating the issue.
Posted Apr 22, 2024 - 13:01 UTC
This incident affected: Explorer API.